Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Transmission issues

Discussion in 'VZ Holden Commodore (2004 - 2006)' started by jd71, May 4, 2019.

Tags:
  1. jd71

    jd71 Member

    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Joined:
    Apr 2, 2016
    Location:
    geelong
    Members Ride:
    05 sv6
    hi guys,

    I have a vz sv6.
    Starting to get some minor tranny issues, when overtaking sometimes makes a unusual noise hard to explain, I guess slipping noise. Also having a slight odd smell inside car after accelerating. Car staggers somewhat going 80 and 100 and uphill. Once or twice I have put it into reverse out of garage and taken a second to go in. Nothing huge but still. I'm just contemplating getting a fluid change over for 275 from tranny place. I don the know if that will do anything. And I should ask for a flush not a changeover right so it's better. I'm considering ditching the car, but they say the devil you know is better then devil you don't. Definitely has a lack of power. I've boughta new fuel filter haven't put it in as I've read some nightmare stories on here of having to replace all fuel line when the clips break. It could also do with new plugs and injectors/fuel pump maybe. I'm just wondering if it's worth getting the tranny service or not what do you guys think?
     
  2. Russell Ward

    Russell Ward New Member

    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    1
    Joined:
    Feb 3, 2019
    Location:
    Petrie 4502
    Members Ride:
    VZ ute v6
    Hello , my first post here so hope I'm ok here. My VZ ute "beeps " while driving . sounds like handbrake alarm but on the dash the gear selector position display shows as though I just put it in Drive. Displays all the positions with D in the box . Then goes back to simply the D.
    I recently replaced all plugs and coils then a problem low voltage battery put the ute in Emergency limp mode. Replaced the battery and all faults cleared. Was checked with auto election at the time. [2 weeks ago]. Thanks in advance for any info .
     
  3. vr_owner

    vr_owner Member

    Messages:
    455
    Likes Received:
    3
    Trophy Points:
    18
    Joined:
    Jul 27, 2006
    Members Ride:
    vr 3.8lt executive
    sounds like a torque convertor dying, mine had the same thing, a service for the trans isnt much and they will diagnose the car at the same time.
     
  4. jd71

    jd71 Member

    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    Joined:
    Apr 2, 2016
    Location:
    geelong
    Members Ride:
    05 sv6
    Thanks, when the car is in neutral seems to be fine, today was stripuggling to do 80kmh like something holding the car back.
     

Share This Page